front lights on a Piko 218 loco

D

DRG11

Registered
14 May 2011
368
0
Roman City of Bath
Hi all,

hoperfully somebody can advise me on how the lighting wires go into a massoth XLS decoder please.

there are 2 wires each end normally joined with the power wires in analogue which puts the light on all the time,

As ive now fitted the XLS decoder does anybody know where these wires now go ? do they just go into the light front and rear ?

cheers
 
PhilP

PhilP

G Scale, 7/8th's, Electronics
5 Jun 2013
23,670
554
Tamworth, Staffs.
I can give you some general information, but am not familiar with the Piko loco's:

Your decoder should have an 'front' and 'rear' light output. These will automatically switch on, dependent on direction of travel.
All function outputs switch to ground (negative) so the other side of your lights will connect to 'decoder +'.
BY DEFAULT, THE LIGHTING OUTPUTS WILL BE FULL TRACK VOLTAGE - 24 Volts!

You will need to discover (wait until someone tells you, on here!) what voltage the bulbs(?) require.
If they are LED's you will need a suitable series resistor, to limit the current.
 
Tanker man

Tanker man

G scale and 5 inch ride on
10 Jun 2015
290
49
Oxford
Somewhere on this site there is a good description of how to connect the lights, it's posted, with a picture, by 'Stockers' I think, if you search the site for DB218 you should find it, I know I have the picture somewhere but am unable to locate it at the moment, on my iPad, if I find it, I'll post it later
Cheers
Dave
 
muns

muns

Moderator
Staff member
GSC Moderator
Massoth used to do a lighting board for the 218 which added Red LED tail lamps. I have attached the old instruction manual for that set which shows how to wire the lighting to an XLS.
 

Attachments

D

DRG11

Registered
14 May 2011
368
0
Roman City of Bath
Hi, many thanks for the replies, will see how i get on, cheers
 
D

DRG11

Registered
14 May 2011
368
0
Roman City of Bath
Hi all, well ive done something wrong as the lights do work, tried to wire up as stated but nothing at all,

could it be a problem with still trying to use the piko lights ?, im not worried about tail/rear lights just the front ones in direction of travel,
 
PhilP

PhilP

G Scale, 7/8th's, Electronics
5 Jun 2013
23,670
554
Tamworth, Staffs.
Did you work out if the original's are bulbs or LED's?
If LED's, are you driving them with the correct polarity?
You DID use current limiting resistors, I presume?
 
Greg Elmassian

Greg Elmassian

Registered
8 Mar 2014
2,906
190
San Diego
www.elmassian.com
Always difficult to give a precise recipe when the fundamentals are not understood.

I would suggest the OP posting pictures showing what wires are hooked to what.

The alternative is learning how electrical circuits work, polarity of leds and current limiting diodes, and that "common" on a decoder for lighting is positive not negative.

Greg
 
dunnyrail

dunnyrail

DOGS, Garden Railways, Steam Trains, Jive Dancing,
25 Oct 2009
15,036
462
71
St.Neots Cambridgeshire UK
I seam to remember when I did my 218 back in Mad days that I did all new Lamps using LED’s powering them using the correct voltage direct from the Chip. I also incorporated blocking Diodes just to be safe with the LED’s. This was all posted on Mad but sadly possibly lost in the change of site.
 
D

DRG11

Registered
14 May 2011
368
0
Roman City of Bath
cheers gents I will start looking into it all, many thanks your help.
 
D

DRG11

Registered
14 May 2011
368
0
Roman City of Bath
Hi all,

Many thanks for all your help ive got them working fully now :) Thankyou for all your ideas with what to do.

Just need to change a bulb now as one had blown.

Thankyou