Massoth CS Update Issue

Diesel2000

Registered
18 Feb 2020
61
9
41
Chicago
Country flag
I'd like to update the firmware on my NAV and do not have the Massoth PC Module at this time, so I'm trying to use the firmware update feature through the 1210z CS.

I've installed the documented VCP driver on my laptop (VCP Drivers - FTDI) and set it to the proper port for the CS when opening the Massoth Service Tool (COM3), but the MST returns “error too many read/write tests” when trying to connect to the CS with the CS in firmware update mode. The CS then reboots when it fails. I've tried reinstalling the driver and noted it came up as COM7 the second time, so I changed that, but still the same issue.

I have Windows 10 on the laptop.

Any idea what the trouble might be? Am I using the wrong VCP driver?
 
Last edited:

Benco

Registered
22 May 2020
55
6
70
UK
Country flag
Have you tried reducing the transmission speed of your Com port. This can be accessed through Devices in Control Panel. I think I reduced mine from 9000 ish to around 3oo.
Ben
 

Diesel2000

Registered
18 Feb 2020
61
9
41
Chicago
Country flag
Have you tried reducing the transmission speed of your Com port. This can be accessed through Devices in Control Panel. I think I reduced mine from 9000 ish to around 3oo.
Ben
Just tried it and still same issue and error.
 

Diesel2000

Registered
18 Feb 2020
61
9
41
Chicago
Country flag
I was able to get this working. My issue was having the CS in boot loader mode as I was trying to launch the MST interface. It will fail when trying to do this. You only put the CS in firmware update mode after launching the MST interface and select the COM port. As someone who works in technology this seemed a bit nuanced.
 
  • Like
Reactions: 1 user