PC Module updating soundfile

T

Trebor

Retired to play with my trains
2 Aug 2018
5
0
Mid-west USA
I have been trying to change a sound file on my LGB 28003. I connected my XLS >3.5 to a LGB Buhler motor. There are no track power connections. I connected the SUSI cable from the PC Module to the decoder port. The power to the PC Module is 22V dc The PC module is connected to my Lenovo 110S laptop by cable.

I get theReading No Data 117 error and then I notice that my PC Module is turned off. The PC Module was on just before I received the error message.

I would accept any suggestions. I am determined to learn how to update firmware, software and sound files.
 
Ralphmp

Ralphmp

Registered
6 Jan 2010
826
15
Herts
Hi Trebor

This sounds like the same problem I had when attempting to do firmware updates to XLS decoders using the SUSI cable from my PC module. Despite much helpful advice and many constructive suggestions from folk on this forum, I could never get it to work. I have therefore stuck with the slower, but in my case more reliable, method of connecting the decoder to the PC module via a couple of cables and accepting it will take a while for the update to complete - I think firmware updates were about 15 mins and sound file updates about 25 mins.

If I remember correctly, I think I also get the "Reading No Data 117" message at the start of the update but then after several seconds the process kicks off and a series of messages like "Block 001 OK", "Block 002 OK" started appearing show the update was under way.

No doubt some of the forum's gurus on this subject will be able to provide you with specific advice / guidance on how to get the update via SUSI cable working. In advance of this, I hope the above suggestions for using the non-SUSI method prove helpful.

Good luck.
 
T

Trebor

Retired to play with my trains
2 Aug 2018
5
0
Mid-west USA
Hi Trebor

This sounds like the same problem I had when attempting to do firmware updates to XLS decoders using the SUSI cable from my PC module. Despite much helpful advice and many constructive suggestions from folk on this forum, I could never get it to work. I have therefore stuck with the slower, but in my case more reliable, method of connecting the decoder to the PC module via a couple of cables and accepting it will take a while for the update to complete - I think firmware updates were about 15 mins and sound file updates about 25 mins.

If I remember correctly, I think I also get the "Reading No Data 117" message at the start of the update but then after several seconds the process kicks off and a series of messages like "Block 001 OK", "Block 002 OK" started appearing show the update was under way.

No doubt some of the forum's gurus on this subject will be able to provide you with specific advice / guidance on how to get the update via SUSI cable working. In advance of this, I hope the above suggestions for using the non-SUSI method prove helpful.

Good luck.
When you say “connecting the decoder to the PC module via a couple of cables”, what type of cables and where on the PC Module?
 
T

Trebor

Retired to play with my trains
2 Aug 2018
5
0
Mid-west USA
When you say “connecting the decoder to the PC module via a couple of cables”, what type of cables and where on the PC Module?
 
PhilP

PhilP

G Scale, 7/8th's, Electronics
5 Jun 2013
23,183
405
Tamworth, Staffs.
When you say “connecting the decoder to the PC module via a couple of cables”, what type of cables and where on the PC Module?
There are four screw-terminal connections..
Two are for power, and two for a 'programming track'. - Though you can wire these directly into the screw terminals on your XLS..
 
Ralphmp

Ralphmp

Registered
6 Jan 2010
826
15
Herts
Thanks Phil - I'd gone to bed when Trebor asked his follow-up question and have only just surfaced from cleaning out an old greenhouse!
 
T

Trebor

Retired to play with my trains
2 Aug 2018
5
0
Mid-west USA
Folks, thank you for your advice. I will give a try today.